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PPA stands for Peak Pairs Analysis, the DigitalMicrograph plug-in for High-Resolution Peak
Measurement and Strain Mapping Analysis.

All results obtained by PPA are fully compatible with the other functions present in DM. For
example, strain maps can be analysed and/or manipulated with functions such as histograms,
statistics (mean, standard deviation, min, max etc.), or using the corresponding buttons, such
as the Profile utility.

The main reference for the algorithm is:

The Peak Pairs algorithm for strain mapping from HRTEM images

Pedro L. Galindo, Stawomir Kret, Ana M. Sanchez, Jean-Yves Laval, Andrés Yafiez,
Joaquin Pizarro, Elisa Guerrero, Teresa Ben and Sergio I. Molina

Ultramicroscopy 107 (2007) 1186—1193

doi: 10.1016/j.ultramic.2007.01.019

This manual will help you to use of the PPA package with some worked examples. There is
also a quick reference guide at the end of this document.

Software requirements

The following is a list of the software requirements necessary to run the PPA plug-in:

- DigitalMicrograph (GATAN™)

- USB Key Driver

-  HREM Mouse Tool Plug-in (Free-ware downloadable from www.hremresearch.com)
- IPU Plug-in (Free-ware downloadable from www.hremresearch.com)
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Software Installation

Installing USB Key Driver
The user key driver should be installed by following the instructions given by the key driver installer.
The key driver installer comes with PPA, or you can find it on our web site.

Installing PPA
PeakPairs.gtk and PeakPairs.dll can be S ecs Fiter.
installed by drag-and-drop copy to the folder Find Peaks..
“Pluglns” (The Pluglns folder should exist ng,:::;eﬁiﬁaps
under a normal installation of the g:g?:;:pff'e"”
DigitalMicrograph.) Repeat Project

Project
When the DigitalMicrograph is launched Z::io\;lm it
after placing the plug-ins into the Pluglns Low Pass Filter..
folder, PeakPairs menu commands will et Reference Base Vectors
appear under “PeakPairs” menu. Ei:'?yre'sf:f:iac:mpoims

Analyze Column Positions...
Histoeram from Spreadsheet
Create Vector Map...
Distortion Correction

Help
About PeakPairs

Installing Mouse Tools

All the files relating Mouse tool plug-in can be K . & AL
installed by drag-and-drop copy to the folder o
“Pluglns.” (The Pluglns folder should exist under
a normal installation of the DigitalMicrograph.)

When the DigitalMicrograph is launched after
placing the plug-ins into the Pluglns folder, the
Mouse tool will appear as an addition to the
toolbar.

Installing IPU Plug-in

PPA uses some functions based on the Intel” MKL (Math Kernel Library) provided by the IPU plug-in.
All the files relating the IPU plug-in can be installed by drag-and-drop copy. Please consult the
ReadMe file that comes with the IPU plug-in.
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Image preprocessing and Basis Vector Selection

Open the file “Test image.dm3” using the DM command File...Open:

Hint: this image has been
generated artificially to show
PPA functionality.

It consists on a dot pattern
where different strains are
present, but not visible at the
naked eye.

All the commands related to PPA are located in the menu Peak Pairs. The first command to
be applied to a new image is to calculate the Power Spectrum of the image:

i1 B: Power Spectrum of; Test image

Power Spectrum

Find Peaks..

Find Peak Pairs
Displacement Maps
Define Reference

Strain Map...

Bepeat Project 4
Project 4
Imaee Group »

Adaptive Wiener Filter...
Low Pass Filter..
Set Reference Base Vectors

Peak Histogram..

Analyze Lattice Points

Analyze Caolumn Positions...
Histogram from Spreadsheet
Create Vector Map...

Distortion Correction 4

Help »
About PeakPairs

Now, using the mouse tool, click on desired
spots. The usual choice is to select the B o € £ T

brightest spots in the spectrum, but those
corresponding to higher harmonics can also
be selected:



The user doesn’t need to hit the spot exactly, Ly @ i

because PPA looks for the local maxima near
the selected point. Anyway, you can zoom in
the spectrum before hitting peaks using the
DM zoom tool:

i1 B: Power Spectrum of Test image

Hint: if you wish to delete any spot,
just click on the mouse mark again
with the SHIFT key down.

Hint: Symmetry in the selection for
each spot is assumed.

IMPORTANT: First and second chosen spots (numbered as 1 and 2) will define the lattice
basis vectors. These spots should be apart from the vertical or horizontal of the central spot, in
order to obtain maximum resolution.

Don’t be surprised if the central spot is not present in the power spectrum. It just indicates that
the mean intensity of the image is zero.

We are now ready to apply a Bragg Filter. This process creates an image where the contrast
resulting from the ordered regions is clearly distinguishable from the background intensity.

( éragg Filter.. >

Find Peaks..

Find Peak Pairs i Brage Filter
Displacement Maps

Define Reference Project Name: |Projectl

Strain Map...

Size:
Bepeat Project 4

Project 4 Custom v 20.0 pixels Apply

Image Group >
S thing Width:
Adaptive Wiener Filter... Lkl ga

Low Pass Filter... l; Oval Ratios |1 0
Set Reference Base Vectors

Peak Histogram.. EXRSIRER]0.0 EELER

Analyze Lattice Points aK
Analyze Caolumn Positions... |
Histogram from Spreadsheet
Create Vector Map...

Distortion Correction 4

Cancel

Help »
About PeakPairs



The shape and size of the Bragg filter must be adjusted such that no loss of information
occurs. In this dialog box we can determine the size (in pixels), smoothing width(in pixels),
oval ratio(height/width) and direction(in degrees) of mask spots.

By pressing the Apply button, the mask described by the chosen parameters may be
previsualized, as it is shown in these two examples:

i/ A: Power Spectrum of Test image

i3 Braee Filter,

Project Name:

Project Neme: [Froject!|

Size
[Custom | oo phels M
Smoothing Width: [50
[V OwalRatio: [fo
g

Size:
[Custom  ~| [loo iy
Smoothing Width: [§0
[V OwlRatio: oo
Direction: [-450 desree
oK Cancel

Let us select the second choice by S :
pressing the OK button, and the Bragg
filtered image will appear immediately.

If Bragg filter parameters are properly
chosen (big masks and a sufficient number
of peaks), the resulting filtered image will
preserve the location of maxima. The
great advantage in using the filtered image
is the reduction of present noise. X
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Peak Pairs Determination

Once we have a Bragg filtered image, the
Eoreer Specinim next step is to locate peaks of intensity in the

Br

Find Peaks image by pressing the Find Peaks option.

En
Displacement Maps
Define Reference

Strain Map.. i Find Peaks

The following dialog box appears:

Bepeat Project 4
Project » [ Invert Peaks
Image Group >
Peak Threshold: |[i§]
Adaptive Wiener Filter...
Low Pass Filter.. Minimum Peak Distance: |5.0
Set Reference Base Vectors
Peak Histogram.. oK | Cancel |
Analyze Lattice Points

Analyze Column Positions...
Histogram from Spreadsheet Note: Let’s ignore by now the parameters in the

Create Vector Map. checkbox. They will be discussed later.
Distortion Correction 4

Help »
About PeakPairs

ragg Filtered Test image

i3 H: Bragg Filtered Test image
- L = - Ll
=
e o O
e
]
e o o
] m
B9 B

e o o
- - -
o o Q

By pressing OK, we get a first set of peaks shown as coloured spots over the filtered image.
Blue dots represent local maxima (8-neighbourhood) on a pixel basis. Red dots represent
refined maxima at subpixel-resolution. Sub-pixel resolution is achieved by fitting a 2D
quadratic function and calculating analytically the maxima, as described in [1].

Sometimes, extra peaks are obtained in this automatic Peak Finding process, especially at the
borders of the image.

Peak Threshold indicates the minimum intensity of a point to be considered as a valid peak.
Peaks having intensities below this threshold will be discarded. To determine a precise value

9 HREM Research Inc.
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of Peak Threshold, a Peak Histogram may be very useful. This can be obtained using the
corresponding option in the Peak Pairs menu.

Power Spectrum
Braee Filter...

Find Peaks..
Find Peak Pairs
Displacement Maps

Define Reference ivi F: Peak Histogram of Bragg Filtered Test image
Strain Map...
. 180
Repeat Project »
Project 4 1%
Imaee Group > 140

120

Adaptive Wiener Filter...
Low Pass Filter...

Set Reference Base Vectors &0
c Peak Histogram.. > =
F.y |, | —43i Do 40
Analyze Column Positions... &

Histogram from Spreadsheet
Create Vector Map..
Distortion Correction >

Help »
About PeakPairs

By looking at the histogram, a reasonable threshold could be the value 2.5. Repeating the Find
Peaks command and choosing Peak Threshold=2.5, all peaks in the border of the image will
be discarded and won’t be considered in any further calculations.

If we want to restrict the distance between peaks, it is possible to define the Minimum Peak
Distance in the same dialog box.

The next step is the calculation of Peak Pairs. This process will find pairs of peaks along two
basis vectors automatically chosen from the user selected Bragg spots (see Additional
functions for selecting the reference basis vectors manually).

Power Spectrum
Brage Filter...

Eind Peak Pairs

Uispiacement Maps

Define Reference

Strain Map...

Repeat Project »
Project 3
Imaee Group 3

Adaptive Wiener Filter...
Low Pass Filter..
Set Reference Base Vectors

Peak Histogram...

Analyze Lattice Points

Analyze Column Pogitions...
Histogram from Spreadsheet
Create Vector Map...

Distortion Correction »

Help »
About PeakPairs

Once all Peak Pairs have been determined, we can proceed to the calculation of displacement
maps using the command Displacement Maps. This generates horizontal and vertical
displacements along the two defined directions (D1h, D1v, D2h and D2v).

10 HREM Research Inc.
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Displacement and Strain Maps calculation

Power Spectrum
Braee Filter...

Find Peaks..

Displacement Maps

gtrain Map...

Bepeat Project »
Project »
Imaee Group »

Adaptive Wiener Filter..
Low Pass Filter...
Set Reference Base Vectors

Peak Histogram..

Analyze Lattice Points

Analyze Column Positions...
Histogram from Spreadsheet
Create Vector Map...

Distortion Correction >

Help »
About PeakPairs

Technical note: PPA uses an automatic selection of contrast and the temperature colour
scale for displaying image values.

If you prefer a grey scale or a different contrast limit, press the right button on the image,
and modify ImageDisplay options properly.

Changing this options will not change the actual values, only its appearance.

A very important step is to define the reference
area, that is to say, the area which is considered to
correspond to the reference lattice.

All displacements and strain values will be
referred to this area. Use the DM ROI tool
(region of interest tool) to select an area on any
Displacement image (D1h, D1v, D2h or D2v):

Once the reference area has been chosen, the user should select the Define Reference option.
This will change the displacement values, so as to obtain a uniform displacement in the
chosen area.

11 HREM Research Inc.
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Power Spectrum
Braee Filter...

Find Peaks..
Find Peak Pairs

Define Reference

Bepeat Project 4
Project »
Imaee Group »

Adaptive Wiener Filter...
Low Pass Filter...
Set Reference Base Vectors

Peak Histogram..

Analyze Lattice Points

Analyze Column Positions...
Histogram from Spreadsheet
Create Vector Map...

Distortion Correction >

Help »
About PeakPairs

The final step is the determination of strain
Power Spectrum .
Braee Filter. maps (€xx,Eyy,Exy and eyy) at the desired angle.
Eind Peaks.. If angle is set equal to 0, horizontal and
Eind Peak Pairs . . .
Displacement Maps vertical directions are assumed to be x and y

ce

— coordinate axis respectively.

-~
= s otrain Map
Project » @

Imaee Group > Option ]

Adaptive Wiener Filter.. Angle of x-ais to harizontal: [00
Low Pass Filter... |

Set Reference Base Vectors ~Show the following images

Peak Histogram..
#Analyze Lattice Points

#nalyze Column Positions... " Symmetric
Histoeram from Spreadsheet [~ Mesn Dilatation
Create Wector Map.. [~ Rotation Anele
Distortion Correction > L

| Owverlay
Help >

#About PeakPairs oK Cancel

There are two options for strain representation:

Overlay: the strain is shown at each atomic column, No overlay: continuous strain maps
and displayed as coloured dots over the original image are shown.

12 HREM Research Inc.
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Once the representation is chosen, a set of 4 images corresponding to (€xx,€yy,exy and eyx) are
obtained

Choosing the x-axis parallel to the picture horizontal axis (i.e. angle zero) and leaving overlay
unmarked, the following image group will be obtained:

Hint: you can modify the color
range by pressing the right
button of the mouse on the
image, and modifying
ImageDisplay options properly.

Default colour range is +5%

The results of the PPA package is the complete strain tensor defined as follows:

Strain values
Ju ou ou ou

_ X _ y _ X _ y
exx— ,eyy— ,exy— , e =

ox ay

Strain tensor:
£ =l %4—% i.e.g =aux £ =% £ =l %4_%
o2lex,  ox T dy  dx

Mean dilatation :

o Ou ) - 1
A =l(%+_1) ie. A =5 Exx+£yy)

o2l ox,  ox,

J
Rotation (in radians and anti-clockwise positive):

As we clearly see in the resulting images, the displacement and strain maps appear to be the
composition of two different sources of deformation. The reason is that distortions due to the
projector lens have been made quite visible in the example.

In the next section, we will show how to remove this distortion using an image of a perfect
crystal taken in the same conditions.

13 HREM Research Inc.
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Geometric distortion correction

All optical systems distort the images they form. CCD cameras and scanners (for digitising
negatives for example) introduce additional distortions. If these geometric distortions are
fixed (what is usual for a given system), it is possible to eliminate them. This is valid not only
for projector lens distortions but also for any other systematic distortions present in the image.

In order to correct the distortions, an image of a perfect crystal is needed. Open the image
“Substrate.dm3”, which corresponds to a perfect crystal image, calculate the Power Spectrum,
and Bragg-filter the image in the usual way, by selecting relevant spots in the Power
Spectrum and using a custom mask at each spot.

X || 7 A: Power Spectrum of Substrate

[Gostom <] os  pbeis M
Smoothing Width: 50
|V Ovel Ratic: ,m—
Direction: [00  desree

0K Cancel

Then calculate the Peak Pairs using the usual commands (Find Peaks followed by Find Peak
Pairs). If we analyze the displacements, we can observe that the image of a perfect crystal is
shown distorted.

The distortion information that allows rectifying the perfect crystal image can be used to
correct distortions in any other image with the same distortion. In order to do so, we have to
the extract distortion information just selecting the Bragg image of the original crystal, and
applying the command Obtain Distortion Info.

14 HREM Research Inc.
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O N E Power Spectrum
| Braee Filter..

Find Peaks...

Find Peak Pairs
Displacement Maps
Define Reference
Strain Map..

Repeat Project
Project
Imaee Group

Adaptive Wiener Filter...
Low Pass Filter...
Set Reference Base Vectors

Peak Histogram...
Analyze Lattice Points
Analyze Column Positions...
Histoeram from Spreadsheet
Create Vector Map..
Distortion Correction

Help
About PeakPairs

This Distortion info image can be saved to disk and used in further analysis having the same
distortion.

In order to rectify the original image with the distortion information obtained from the perfect
crystal image, just apply the Correct Distortion on the Target Image using the Distortion
information obtained from the reference (Perfect Crystal), as follows:

Power Spectrum
Braee Filter..

1. Open the Correct Distortion dialog

Find Peaks..
Find Peak Pairs
Displacement Maps
Define Reference
Strain Map...

2. Select the Target Image (Test Image)

3. Select the Distortion Info (Distortion Info of
Substrate)

Bepeat Project
Project
Imaege Group

Adaptive Wiener Filter...
Low Pass Filter..
Set Reference Base Vectors

i Correct Distortion

IEIGEANERCES: [estimage 918k v

Peak Histogram..
fAnalyze Lattice Points
#Analyze Column Positions...
Histogram from Spreadsheet
Create Vector Map...
Distortion Correction »

Distortion Info: IAE: Distortion Info of Substrate 2757k ﬂ

orrect Distortion..

oK | Cancel |

Help
About PeakPairs

ctify Imaee..

15 HREM Research Inc.
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This will produce a corrected image, where
all distortions due to the microscope have
been eliminated.

We can now proceed to analyze this image in
the usual way to get the final results:

Power Spectrum

Bragg Filtering

Find Peaks

Find Peak Pairs

Displacement Maps

Define reference

Strain maps

Nk

[

w5 40: D1h B |-k MEE] [ET S (=] g

W W m—— .

If we plot a horizontal profile across exx and a vertical one across eyy, we get the expected
results (exx=0.1 and eyy=0.05).

5 F: Profile Of exx D@@ ira R: Profile Of eyy E‘@@
0.

on

o

009

0.8

007

0.6

005

004

003

002

0o

0.00 '- -~ — '-v“"nv-

200 250 300 %0 400

-0u

16 HREM Research Inc.



Additional functions

Lattice Analysis

PPA for DM Manual

Selecting the Bragg filtered image after Peak Pairs, displacements maps and strains
calculation, and using the Analyze lattice points command will generate a spreadsheet

including the following columns (one row for each each lattice peak):

- Peak position at subpixel resolution (X,y coordinates)

- Peak intensity (gray level)

Power Spectbrbuhl o

Atomic column strain tensor (exx,eyy,exy and eyx).

B-m
=

X Y Height exx eyy exy eyx
Braee Filter... R5z2 [13.7891 498.337 2.94401 -0.0385771 |0.0326224 | 0.00351744 |0.00026705 | |
R52 |0.137027 | 498.336 2.88483 0.0 0.0 0.0 0.0
Find Peaks.. R34 |88.6993 498.33 2.84837 0.0131021 |0.0147874 | 0.00595048 | 0.00640648
Find Peak Pairs RE5 _ |118.783 498.321 3.04162 -0.00473235 0.022545 0.00202371 | -0.00563105
Bisplacement Maps R5¢ |148.628 498.316 2.77591 0.00111148 | 0.0155802 | -0.00361963| 0.00403706
— R57 |233.638 498.304 2.84772 -0.00324309 0.0241627 | -0.00241677| 0.00655233
Define Reference R58 |283.703 498.292 2.95035 -0.004056 | 0.0307521 |0.00322721 |0.00774002
Strain Map... R55 | 454.408 498.282 2.390393 0.0409217 | 0.0112837 | 0.00500056 |0.0153961
— —— REG_|345.156 498.278 3.04825 0.0459432 | 0.0322419 | 0.00881688 |0.0100115
Bepeat Project » R 163,681 498.276 2.91414 0.00631584 | 0.0125755 | -0.00276131|-0.00331238
Project > 253.671 498.255 2.98547 0.00231427 | 0.00710628 | 0.00303033 | -0.00722775
Image Group » 392.073 498.244 2.88768 0.0405167 | 0.0126758 | -0.00010736| -0.004102
s 360.833 498.226 2.83311 0.0435916 | 0.025963 | 0.0101185 | -0.0122214
Adaptive Wiener Filter.. Rl Jaz3. 20 498.223 2.86307 0.0497911 | 0.0124825 | -0.00021804|0.00234132
= ) REE_|103.793 498.221 2.89016 0.00239009 | 0.00940409 | -0.0158032 | 0.000178943
Low Pass Filter... R67 | 470.043 498.163 3.48381 0.036427 | 0.0127087 | -0.00105125 -0.00765104
Set Reference Base Vectors RES_ | 446.6 490.713 3.06305 0.047881 | 0.0458879 | -0.010032 | 0.000507943
" RES _|s51.1566 490.698 3.47399 -0.00158433 0.0638156 | -0.00823113| 0.00150005
P oheETs R76__|306.133 490.663 3.29802 0.01744 0.0591531 | -0.00345342| -0.0124608
fnalyze Lattice Paints R71_|201.147 490.661 3.35902 0.00469658 | 0.0637819 | 0.00707607 |0.00337314
T TRl 1 M T R7Z_|321.756 490.654 3.27754 0.0469193 | 0.0647467 | 0.00155921 |0.0111361
o R73_|261.252 490.643 3.44382 0.00153094 | 0.0516147 | 0.00242396 | -0.00463298
Histoeram from Spreadsheet R74_|s08.027 430.632 3.34222 0.0 0.0 0.0 0.0
Create Vector Map... R75_|399.894 490.633 3.23887 0.0404363 | 0.0467592 | 0.00137114 | -0.00028703
Distortion Gorrection » R76 _|171.153 490.615 3.45244 -0.00315837 0.0434635 | -0.0142066 | 0.00183251
= R77_|384.289 490.604 3.21326 0.0352444 | 0.0490219 | -0.0147539 | -0.00085547

About PeakPairs

It is also possible to get a histogram from the Spreadsheet by using the Histogram from
Spreadsheet command, thus obtaining a different histogram for each column in the

spreadsheet.

Power Spectrum
Braee Filter..

Find Peaks..

Find Peak Pairs
Displacement Maps
Define Reference

Strain Map...

BRepeat Project »
Project »
Image Group »

Adaptive Wiener Filter..
Low Pass Filter..
Set Reference Base Vectors

Peak Histogram..
Analyze Lattice Points

< Histoeram from Spreadsheet >

= =
Distortion Correctiol 4
Help »

Ebout PeakPairs

1.5

35
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Analyze column positions

Once Peak Pairs have been located, it is possible to analyze column positions with respect to
its relative position within the grid. This is very useful when more than one atomic column is
present for each lattice point. For example, in the case of zincblende materials in the [110]
direction, we can evaluate peak intensities at cation and/or anion column positions. In order to

do so, go through the following steps:

Then, the user will have the option to
decide between calculating the distances
from the checked point to other points, or
the angles subtended by two adjacent
points. The results will be shown in the
image, and the peak intensity at each point
will be stored in a datasheet.

Power Spectrum
Braee Filter..

Find Peaks..

Find Peak Pairs
Displacement Maps
Define Reference

Strain Map...

Bepeat Project 4
Project 4
Imaee Group »

Adaptive Wiener Filter...
Low Pass Filter...
Set Reference Base Vectors

Peak Histogram..

Analyze Caolumn Positions...

_. LA O Wl =F=Tm =
Create Vector Map...

Distortion Correction 4

Help »
About PeakPairs

Calculate Peak Pairs in the usual way

Use the rectangleROI tool to choose the
area of interest in the original image

Choose the point(s) of interest inside the
image (i.e. any local maxima of intensity)

Apply the Analyze Column Positions
command

Select the image and Bragg Filtered
images in the corresponding dialog

i3/ Analyze Column Positions

Distance | Angle ‘
V1l

Distances from the checked paint(s] ta
other points will be evaluated.

0K Cancel

EEX

negz0zz
0882584
147301

0643538
0634073
0&47895
0e26066 o
0841383
0665945
0&92594
0531213
0635945
0889551
0705853
0760515
0716727
0629241 i

243474
246387
248799
247151
244161
246636
246192
243495
247397
249516
247197
248752
246058
246362
247818
247994
245821

olololalolo|alalelalalelolalalolo|wBE
olojolojolojalojolololololololo|o|n

The number of columns in the datasheet will be equal to the number of points of interest

chosen by the user.
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Create Vector maps

It is possible to create vector maps from strain maps. To do so, just select the Create Vector
Maps command after a complete strain analysis has been made. Then, select two strain maps
in order to determine the associated vector map.

Power Spectrum
Braee Filter...

Find Peaks..

Find Peak Pairs
Displacement Maps
Define Reference

Strain Map...

Bepeat Project 4
Project »
Imaee Group »

Adaptive Wiener Filter...
Low Pass Filter...
Set Reference Base Vectors

Peak Histogram..

Analyze Lattice Points

Analyze Column Positions...
aadsheet

OET QTFrrrer

Cr

eate Vector Map
orterTCOTECion

Help »
About PeakPairs

iv3/D: Untitled

-
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Adaptive Wiener Filtering

The Wiener filter is widely used for image restoration and calculates the optimal filter for the
removal of noise from a signal which is corrupted by the measuring process itself. It assumes
that if noise is present in the system, then it is considered to be additive white Gaussian noise.

After selecting the original image, and applying the Adaptive Wiener Filter in the menu, the
user should decide the size of the windows used for calculating the Adaptive Average and the
Noise Estimation, as follows:

Power Spectrum
Braee Filter..

Find Peaks..
Find Peak Pairs

Displacement Maps r
Define Reference ia Wiener. Filter @

Strain Map...

. MNew Project: |3
Bepeat Project 4 HETN
Project » Adaptive Aversge: [I @+ pixels
Image Group >
Noise Estimation: [I” @+1 pixels

Adaptive Wiener Filter...
i oK | Cancel |

Set Reference Base Vectors

Peak Histogram..

Analyze Lattice Points

Analyze Caolumn Positions...
Histogram from Spreadsheet
Create Vector Map...

Distortion Correction 4

Help »
About PeakPairs

In a typical Peak Pairs session, if Wiener filtering is desired, it is usually the first operation to
be applied to the original image. The result of the Wiener filtering operation on PPA Testl
image and respective Power Spectra (Adaptive Average =3, Noise Estimation=3) is depicted
below.

ower Spectrum of A.
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Low Pass Filtering

In order to generate a Low-Pass filtered image, we simply select the input image and use the
Low Pass Filter command in the menu. The strength of the filter is defined by the radius of
the mask in pixels (the highest the radius, the strongest the filter):

Power Spectrum
Braee Filter...

Find Peaks..
Find Peak Pairs

Displacement Maps
Define Reference i3/ Low Pass Filter @
Strain Map...

Repeat Project , New Project: |Projectt
Project » Radius(pixal}
Image Group »

- [1.6]

Adanti iter

Low Pass Fiter. 0K | Cancel |

rs

Peak Histogram..

Analyze Lattice Points

Analyze Column Positions...
Histoeram from Spreadsheet
Create Vector Map...

Distortion Correction 4

Help »
About PeakPairs

In the following figure, the resulting images after the application of a Low-Pass filter to the
lower left part of PPA Testl image with different radius are shown:

Original image Low Pass Filtered Low Pass Filtered
(right-lower corner only) (radius=0.8 pixels) (radius=1.6 pixels)
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Setting the Reference Base Vectors manually

It is possible to manually set the reference base vectors. In order to do so, we need a filtered
image to reduce a random noise, obtained using available options (Bragg, Adaptive Wiener or
Low-Pass filtering).

Once a filtered image has been selected, to e B: LPF of PPA Test 1

manually define the Reference Base vectors, - - .
use the Mouse Tool to select 3 points in the
order (origin of both vectors, terminal point
of vector 1, terminal point of vector 2), so
that the directions of the desired reference
base vectors are described approximately by

the directions of vectors 15 and 1_3.

=LY A@:>

Approximate directions
as described by the user

The precise magnitude and direction of both reference base vectors are calculated, when
applying the Set Reference Base Vectors command, as the average of all the vectors included
in the parallelogram described by these 3 points having their extremes at intensity maxima
peaks and the same approximate directions.

PeakPairs =
P S 4 i B: LPF of PPA Test 1
Power Spectrum .
Braee Filter.. a8 e &
) N B N BN OB e
Find Peaks.. - - . & .

Find Peak Pairs
Displacement Maps
Define Reference
Strain Map...

Bepeat Project 4
Project 4
Imaee Group »
Adaptive Wiener Filter...

< Set Reference Base Vectors >

Peak Histogram..

Analyze Lattice Points

Analyze Caolumn Positions...
Histoeram from Spreadsheet
Create Vector Map...

Distortion Correction 4

T

Reference Base Vectors

Lelp ‘ ’ (average of all vectors in this area)
About PeakPairs
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Image rectification

This option allows the user to rectify an image of a perfect crystal, using Peak Pairs
information.

Open the image “Substrate.dm3”, which corresponds to a perfect crystal image and calculate
the Power Spectrum.

i3 Braee Filter

Project Name: |Project!

Size:

Custom v 5.0 pixels Apply
Smoothing Width: (5.0
- v Owal Ratio: 1.0

Direction: 0.0 degree
0K | Cancel

Bragg-filter the image in the usual way, by selecting three spots in the Power Spectrum and
using a custom mask at each spot.

Then calculate the Peak Pairs using the usual
commands (Find Peaks followed by Find
Peak Pairs)

Then calculate the displacements using
Displacement Maps

The information contained in the resulting
displacements is dominated by the
geometrical distortions.

Given that the image corresponds to a perfect crystal, we can get a rectified image. In order to
do that, just select the Bragg Filtered image and apply the Rectify image command.
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Power Spectrum
Braee Filter..

Find Peaks..

Find Peak Pairs
Displacement Maps
Define Reference

Strain Map...

Repeat Project 4
Project 4
Imaee Group 4

Adaptive Wiener Filter...
Low Pass Filter...
Set Reference Base Vectors

Peak Histogram..
Analyze Lattice Points
Analyze Column Positions...
Histogram from Spreadsheet
Create Vector Map...

Distortion Correction Correct Distortion...

=5 =]

Help
About PeakPairs

PPA for DM Manual

i H: Bragg Filtered PPA

Rectify Image

Base Vector 1
Length: I (10.1593)
Angle: |-53.4 [-53.3717)

Base Vector 2

Length: |8.1 9 [8.18619)
Angle: I-1 731 (173112

0K | Cancel |

This will produce a rectified image of the perfect crystal using the local distortions at each
point of the image. To verify this point, apply a complete analysis process to the rectified
image (Power Spectrum-Bragg Filter-Find Peaks-Find Peak Pairs-Displacements Maps), we

observe that distortions have been corrected.
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Appendix

Some useful DM tricks

DM ROI tool:

() +ew

Hint: to select a square area, hold down SHIFT.
To select powers of two, hold down SHIFT-ALT.

DM zoom tool:

k@/}'*

HREM Mouse tool

Eaofr)

Hint: to demagnify, press ALT.

Hint: to delete any spot, just
click on the mouse mark with
the SHIFT key down.

DM Image Display Option

( ImageDisplay...

Hint: to change the color map
of any image, press the right
mouse button on it, select
ImageDisplay, and modify the
options as desired.

For example, it is useful to set
manually the range of the
colormaps to be the same, so as
to be able to compare them.
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Quick Reference Guide

The PPA Main Menu

Power Spectrum
Braee Filter...

Find Peaks...

Find Peak Pairs
Displacement Maps
Define Reference

Strain Map...

Repeat Project 4
Project 4
Image Group 4

Adaptive Wiener Filter...
Low Pass Filter..
Set Reference Base Vectors

Peak Histogram..

Analyze Lattice Points

Analyze Column Positions...
Histoeram from Spreadsheet
Create Vector Map...

Distortion Correction 4

Help »
About PeakPairs

The commands in the PPA menu are described below.

Command Description

Power Spectrum Calculates the Fourier transform of the front most
image.and displays the power at each frequency
(commonly called the Power Spectrum).

Bragg Filter... Calculates Bragg Filter for the spots selected in the
Power Spectrum. Shape and size of the masks can
be defined by the user.

Note: spots should be selected previously in the
Power Spectrum using the Mouse Tool.

Find Peaks... Locates peaks of intensity in a filtered image. A
threshold for the minimum allowed peak intensity and
a minimum distance for peaks can be defined.

Find Peak Pairs Calculates pairs of peaks along two basis vectors
automatically chosen from the first user selected
Bragg spots

Displacement Maps Generates horizontal and vertical displacements
along the two directions defined by the basis vectors
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PPA for DM Manual

Changes the displacement values, so as to obtain a
uniform displacement in the chosen area.

Note: the area should be selected previously using
the ROI tool on any displacement image

Strain Map...

Calculates strain maps (exx,€yy,exy and eyx) at any
desired angle.

Repeat Project
(see sub menus)

Allows strain images and other output to be
generated directly from the front most HREM image,
exactly as for a previous project. Also allows to save
details of the current project for later use (even in
other sessions of DM).

Project Menu to manage all the images in a particular
(see sub menus) project.
Image Group Menu to close or save groups of images within a

particular project.

Adaptive Wiener Filter...

Calculates and applies an adaptive Wiener filter for
the removal of noise from the image.

Low Pass Filter...

Calculates and applies a Low Pass filter to the image

Set Reference Base
Vectors

It allows to manually set the reference base vectors
on a Bragg or Low-pass filtered image

Peak Histogram...

It calculates a histogram of peaks intensities, helping
the user to determine a precise value for Peak
Threshold

Analyze Lattice Points

Generates a spreadsheet of data (peak position,
peak intensities, strain values) for each peak

Analyze Column

Analyzes column positions with respect to its relative

Positions... position within the grid

Histogram from Calculates a different histogram for each column in
Spreadsheet the spreadsheet

Create Vector Map... Create vector maps after a complete strain analysis

Distortion Correction
(see sub menus)

It eliminates systematic distortions present in the
image

Braqq Filter Dialog

The components of the dialog are described below.

Dialog

7 Braee Filter @

Project Name: |Project!

Size:

Custom vl 20.0 pixels  Apply
Smoothing Width: |5.0

.........................

Direction: |0.0 degree

0K |

Cancel

| Component

| Description
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Project Name Name given to the group of images and results

Size Defines mask radius of hard cut-off (beyond which
values are set to zero).

Smoothing Width Specifies mask smoothing width in pixels

Oval Ratio Defines the shape of the oval, as major to minor axis
ratio

Direction Sets the prescribed masks angle, in degrees

Find Peaks Dialog

Dialog i3 Find Peaks %)
[ Invert Peaks

Peak Threshold: |m
Minimum Peak Distance: |3 Ju]

0K | Cancel |

Component Description

Invert Peaks It allows the user to calculate intensity minima
(instead of maxima)

Peak Threshold Specifies a minimum for the intensity of allowed
peaks

Minimum Peak Distance | Specifies a minimum distance between allowed
peaks

Strain Map Dialog

Option |

Angle of x—axs to horizontal: |:|Ig

Show the following images
v Strain Matrix

(" Independent
(¢ Symmetric
|V Mean Dilatation
v Rotation Angle

[T Dwverlay
oK I Cancel |
Option Description
Angle of x-axis to Specifies the angle of the direction to be considered x
horizontal axis.

You can specify the orientation of the x-axis by
placing a Line ROI on the HREM image. In this case,
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the angle of the Line ROI appears here automatically.

Note: If angle is set equal to 0, horizontal and vertical
directions are assumed to be x and y coordinate axis
respectively.

Strain Matrix

Specifies the images to be shown

Independent

Images of du/dx, du/dy, dv/dx, dv/dy to be displayed

Symmetric

Images of &, &yy and &y, to be displayed.

Mean Dilatation

Image of 0y, to be displayed (average of exxand &yy).

Rotation Angle

Image of wyy to be displayed. Values in degrees and
anticlockwise positive.

Overlay

Shows the strain at each atomic column, and
displayed as coloured dots over the original image

Repeat Project Sub-Menu

Repeat Current Project..
Project » Repeat Saved Project..
Save Current Project As..

Clean up Project List..

Image Group

Adaptive Wiener Filter..

Component

Description

Repeat Current Project

Repeats the same operations as carried out in the
current project on the front most HREM image.

Repeat Saved Project

Repeats the same operations as carried out in a
saved project on the front most HREM image.

Save Current Project As

Saves the details of the current project for later use.

Clean up Project List

Removes project details.

Repeat Current Project Dialog

Dialog

i Repeat @
New Project:

Select
(" Find Peaks
(" Find Peak Pairs
(" Displacement Maps
(¢ Strain Map

oK I Cancel |

Component

Description

New Project

Defines the name of the new project.

Find Peaks

Repeats Find Peaks Operation.
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Find Peak Pairs

Repeats Find Peak Pairs Operation.

PPA for DM Manual

Displacement Maps

Repeats Displacement Maps Operation.

Strain Map

Repeats Strain Map Operation.

Repeat Saved Project Dialog

Dialog

w5 Repeat @
Repeat Project: IProiectI v I

Select
(" Find Peaks

New Project:

(" Find Peak Pairs
(" Displacement Maps
(¢ Strain Map

oK I Cancel |

Component

Description

New Project

Defines the name of the new project.

Repeat Project

Choose the name of the saved project.

Find Peaks

Repeats Find Peaks Operation.

Find Peak Pairs

Repeats Find Peak Pairs Operation.

Displacement Maps

Repeats Displacement Maps Operation.

Strain Map

Repeats Strain Map Operation.

Save Current Project As... Dialog

Dialog # DieitalMicroeraph
Project Name:
oK | Cancel |
Component Description

Project Name

Defines the name of the save project.

Clean up Project List... Dialog

Dialog

i Clean up Project @

Project: |Proiect1 v I

oK |

Cancel |
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Component Description
Project Chooses a project name to remove from the project
list.
Project Sub-Menu
Repeat Project g I
Image Group >

Adaptive Wiener Filter..
Low Pass Filter...
Set Reference Base Vectors

Component Description

Hide Hides all the images in a project.

Show Shows all the images in a hidden project.

Save Saves all the images in a project (with save dialog
window).

Close Closes all the images in a project without saving.

Adaptive Wiener Filter Dialog

Dialog 5 Wiener Filter %]
MNew Project: |

Adsptive Aversge: |1 2+ pixels

Noise Estimation: [I 2+ pixels

oK | Cancel |
Component Description
New Project Name given to the group of images and results
Adaptive Average Window size [(2N+1)x(2N+1) pixels] to be used in the
calculation of the adaptive average
Noise Estimation Window size [(2N+1)x(2N+1) pixels] to be used in the
calculation of the noise estimation

Low Pass Filter Dialog

Dialog 7 Low Pass Filter @

New Project: |Proie ctl

Radius(pixal}
[1.6]

oK | Cancel |
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Component Description
New Project Name given to the group of images and results
Radius(pixel) The radius of the mask in pixels

Peak Histogram Dialog

Dialog 75 Peak Histogram @
[ Invert Peaks
Minimum Pesk Distance: [
oK | Cancel |
Component Description
Invert Peaks It allows the user to calculate intensity minima

histograms (instead of maxima)

Minimum Peak Distance

Specifies a minimum distance between allowed
peaks

Analyze Column Positions Dialog

The user will have the option to decide the distances and/or angles to be evaluated.

Distance Tab

s Analyze Column Positions @

Diztance I Angle I

1 [ 2 3

Distances from the checked point(s) to
other points will be evaluated.

oK I Cancel |

The number of each check box corresponds to the assigned number to the mouse
click. All the distance(s) from the checked point to other points will be calculated.

Angle Tab

s Analyze Column Positions @

Distance Angle ]

1 [ 2 3

Checked point(s) will be a vertex of angle(s)
subtended by two other points.

oK I Cancel |

The number of each check box corresponds to the assigned number to the mouse
click. All possible angle(s) whose vertex corresponds to the checked point will be

calculated.

32 HREM Research Inc.



PPA for DM Manual

Distortion Correction Sub-Menu

| Create Vector Map.. [Eees it n i
It Distortion Correction Correct Distortion... 3
|77 | Obtain Distortion Info

| Help

Ahnut PeakPairs N Bectlfy Image B

Command Description

Correct Distortion Rectifies any distorted image using the distortion
information obtained previously from an undistorted
sample using the “Obtain Distortion Info” command
below.

Obtain Distortion Info Extracts distortion information from the Bragg image
of an undistorted crystal after calculating Peak Pairs.
This information will be used by the “Correct
Distortion” command above.

Rectify Image... Rectifies an image of an undistorted crystal after
calculating Peak Pairs.

Default basis vector are automatically chosen from
the first and second selected Bragg spots. Basis
vectors can also be manually specified/modified by
the user.

Rectify Image Dialog

Dialog i Rectify Image @

Base Vector 1

Leneth: |G (106069)
Angle: |-450 (-44 3966)

Base Vector 2

Length: 105 (105089)
Angle: (450 (45 0048)

oK | Cancel |
Component Description
Length Length of base vector considered for image
rectification, measured in pixels
Angle Angle of base vector considered for image
rectification, measured in degrees
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